Problems logging in

Incident Report for MJ Freeway

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 17:19 UTC

Monitoring

The system is now allowing logging in. We will continue to monitor the system for further issues.
Posted Nov 19, 2025 - 16:39 UTC

Investigating

We are currently investigating this issue.
Posted Nov 19, 2025 - 16:30 UTC
This incident affected: Retail, Manufacturing, and Cultivation.