Reports of slowness
Incident Report for MJ Freeway
Resolved
MJ Platform should be running at normal speed now. We will continue to monitor for any further issues.
Posted Jan 29, 2025 - 19:10 UTC
Investigating
We have reports of slowness and we are looking into it now
Posted Jan 29, 2025 - 18:49 UTC
This incident affected: Retail, Manufacturing, and Cultivation.