Plants not loading on the plants listing page

Incident Report for MJ Freeway

Resolved

This issue with the plants loading has been resolved.
Posted Sep 18, 2025 - 19:27 UTC

Monitoring

The fix has been implemented and plants should be loading now.
Posted Sep 18, 2025 - 19:17 UTC

Identified

We have identified the cause and are working on a fix
Posted Sep 18, 2025 - 19:11 UTC
This incident affected: Cultivation.