Problems Checking in Patients and Completing Sales in PA

Incident Report for MJ Freeway

Resolved

The Patient Registry is working properly now.
Posted May 30, 2025 - 22:14 UTC

Update

We are continuing to work with the Registry provider. Not all transactions seem to be affected.
Posted May 30, 2025 - 20:33 UTC

Update

We are still working with the State Registry provider.
Posted May 30, 2025 - 20:06 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 30, 2025 - 19:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 30, 2025 - 19:19 UTC

Identified

The patient registry is down. We are working with the state registry provider for resolution
Posted May 30, 2025 - 19:17 UTC

Investigating

We Are investigating the reports
Posted May 30, 2025 - 19:13 UTC
This incident affected: Retail.